Camen Design Forum

Firefox and OGG

append delete theraje

Sup?

Been wondering for a while now if Firefox no longer supports OGG audio files. It hasn't played sounds I've added to my game engine for a few months, now. Even after a few updates, running in safe mode, checking the config options...

Couldn't find any good info Googling. Other than it seems to be broken for some, but not for others.

Anyone have any information on this they could share?

Reply RSS

Replies

append delete #1. Martijn

Hmm. Vorbis encoded audio in an Ogg container should still work. Are the files offered under the right MIME type? I’ve seen Firefox struggle with guessing the right MIME on media files.

Otherwise you might want to try WebM instead of Ogg. This is actually encouraged by Mozilla since “ it provides a better compression to quality ratio”. It will depend on what browsers you want to support (and how far back).

Further reading: https://developer.mozilla.org/en-US/docs/HTML/Supported_media_formats

append delete #2. theraje

Not sure about the files. I tend to record and/or edit sounds and export them to OGG using Audacity. Maybe a bug in their exporter?

Either way, I'll look into this article. Thank you!

:: @theraje added on 16 Apr ’14 · 09:08

Well, sadly, Audacity doesn't support exporting WebM format. Any suggestions of a good (preferably free) audio editor that supports WebM exports?

append delete #3. theraje

Actually, I'm wondering if I'm just doing something completely wrong. I can't get WAV, MP3, or OGG files to play in Firefox at all. When I use (new Audio()).canPlayType("audio/ogg; codecs=vorbis"), I get "probably." But when I try to play any audio file, nothing happens.

I have verified that the audio constructor is returning an audio element (I am creating audio elements dynamically, FYI), with the src set correctly, but no sound is audible. Sound works fine elsewhere. But, for some reason, sound WILL NOT play on the page I'm working on. (It seems I'm just really good at failing.)

:: @theraje added on 16 Apr ’14 · 10:09

From what I can tell, the audio is loading. It is technically "playing" (I set currentTime to 0, use the play function, and the currentTime changes to 3.whatever, which seems right), I just hear no sound. With the OGG, MP3, and WAV. No sound, whatsoever, but everything else seems as it should be.

I know that there isn't a sound problem with my laptop or with Firefox, as other Web sites (YouTube and such) play sound fine. The sound files play fine when I open them in other audio programs. But I guess I truly just was never cut out to do this type of stuff (which may explain why I've gotten nowhere with it in the 15 years I've been trying).

append delete #4. TCB

Any suggestions of a good (preferably free) audio editor that supports WebM exports?

I use the Miro Video Converter (http://www.mirovideoconverter.com/). It's drag and drop simple. You get what you get, though. It's not for someone who wants to tweak everything just so.

:: @TCB added on 16 Apr ’14 · 17:35

oops! Just noticed the "audio converter". Not sure how this will handle just audio.

append delete #5. theraje

Okay. So I figured it out. I was having issues with the Silverlight plug-in not playing sound in Firefox. According to the help info, one suggestion was to go to Control Panel. And use the volume mixer there to check the sound volume. (I tend to use the system tray applet to control my volume, bypassing the full mixer.)

Next to the system volume, I saw that the volume slider for Firefox was muted... I hit the mute button to enable the volume. Lo and behold, the sound now plays fine.

FaceDeskHeadPalm!

append delete #6. Chintak

Good man

Reply

(Leave this as-is, it’s a trap!)

There is no need to “register”, just enter the same name + password of your choice every time.

Pro tip: Use markup to add links, quotes and more.

Your friendly neighbourhood moderators: Kroc, Impressed, Martijn